You are here: Home / Documentation / How To's / How to fix a Products.ContentWellPortlets AttributeError on older Plone versions (pre-3.1.7)

How to fix a Products.ContentWellPortlets AttributeError on older Plone versions (pre-3.1.7)

by nguyen — published Jan 18, 2011 12:19 PM, last modified Aug 16, 2016 10:50 AM
AttributeError on portal_membership adding a portlet above or below the content area

See the fix as described at https://weblion.psu.edu/trac/weblion/ticket/977 

Check if you have plone.app.layout < 1.1.5.  1.1.5 has a fix in the view_url method that handles correctly how to obtain the portal_membership object.

If you can't upgrade plone.app.layout to 1.1.5 because of another specific plone.app.layout version requirement, you can patch that method on the file system with the method from 1.1.5 at http://svn.plone.org/svn/plone/plone.app.layout/tags/1.1.5/ and restart your Zope.

Navigation