You are here: Home / Documentation / How To's / How to change versions of Plone in your Vagrant install

How to change versions of Plone in your Vagrant install

by nguyen — published Oct 11, 2014 12:30 AM, last modified Aug 16, 2016 10:50 AM
downgrading from Plone 5.0a2 to 4.3.3

New info below! Thanks to Steve McMahon :)

The Vagrant installer is a very nice, easy way to set up Plone.

If you recently used the Vagrant install but found Plone 5.0a2 instead of the Plone 4.3.3 you expected, here's how to change it.

Edit the Vagrantfile and change the line

UI_URL = "https://launchpad.net/plone/5.0/5.0a2/+download/Plone-5.0a2-UnifiedInstaller.tgz"

to

UI_URL = "https://launchpad.net/plone/4.3/4.3.3/+download/Plone-4.3.3-UnifiedInstaller.tgz"

Save the file.

Run these commands.  Some of them may not be necessary, depending on whether you've run vagrant recently.

vagrant halt
vagrant destroy
vagrant up

Alternatively go to Github.com

Steve McMahon suggests going to Github.com and downloading this directly:

https://github.com/plone/plonedev.vagrant/archive/4.3-maintenance.zip

and that this is available via the "Branch" dropdown at

https://github.com/plone/plonedev.vagrant/

which takes you to 

https://github.com/plone/plonedev.vagrant/branches

 

Navigation