You are here: Home / Documentation / How To's / Fix for plone.app.theming 1.1 breaking jQuery in Plone 4.2

Fix for plone.app.theming 1.1 breaking jQuery in Plone 4.2

by nguyen — published Jul 21, 2013 04:52 PM, last modified Aug 16, 2016 10:49 AM
if the @@theming-controlpanel doesn't function anymore

The problem is that collective.js.jqueryui 1.10.2 and up requires jQuery > 1.6.  If buildout pulls down jQuery 1.9.1, that seems to break plone.app.theming 1.1 on Plone 4.2 (it did for me).

The fix is to pin collective.js.jqueryui to 1.10.1.2.

 

Navigation